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Radio Discovery Tool (RDT) Instruction Manual for RDT Standard and Pro 

Version 1.2 

Welcome to the Radio Discovery Tool (RDT). RDT is meant for use with Icom F3400/F5400/F4400/F6400 

radios (hereafter referenced as the “Icom radio”). RDT now also comes in a “Pro” version that adds 

support for Icom F7000 series products as well as Icom’s R30 receiver. 

RDT provides a method of converting voice logs from the Icom radio in an easy to view table format to 

playback voice and view its abundant metadata. At the same time, it creates a .kml file that can present 

voice data fully mapped on Google Earth. 

RDT also can convert GPS and Power log data from the Icom radio for full viewing on Google Earth if the 

radio supports those features. 

Finally RDT takes voice files recorded on the Icom radio and properly formats and places them for use as 

custom channel announcements if the radio supports that feature. 

What’s New in RDT 1.2 (Standard Edition) 

• License activation screen updated to provide support for upgrades to RDT Pro 

Introducing RDT Pro 1.2 

• Support for Icom F7000 Series Radios (Convert Voice Log and Create Channel Announcement 

Functions Only) 

• Support for Icom R30 Radio (Convert Voice Log Function and Convert GPS Log Functions Only) 

Source 

You can get the latest version of RDT and RDT Pro from www.willowsound.com. The latest version of 

this manual can also be downloaded from that website. 

Disclaimers 

This product relies on data derived from the Icom radio and is no more accurate than the data derived 

from that device or the Google Earth tool used to present much of the data. This product is meant as an 

aid for troubleshooting problems with radio communications as well as incident analysis. It is not meant 

to be a navigational aid (and does not provide real-time GPS locations) of any kind and events depicted 

should be verified independently depending on the severity of the issue. 

Prerequisites 

All versions of RDT use logs derived from SD card recordings on the Icom radio. In that regard, an SD 

card inserted into the Icom radio is required for this product to function. 

For voice log conversions, RDT requires that voice logging be activated on the Icom radio of choice. It is 

strongly suggested that the GPS be activated also to take maximum advantage of what RDT can do. 

Please see the settings on your Icom radio as shown below. 

http://www.willowsound.com/
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F3400 & F5400 Series Radio 

 

Activate Call Record 

 

Screen shot from non-RR firmware 2.0. Activate GPS by turning “GPS” to “ON”. Note that in this screen you can also 

activate GPS Auto Log by setting the field to “ON”. Interval Timer set to 30 seconds – can go to every 5 seconds as 

needed  
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Screen shot from RR Firmware 2.6G. Activate GPS by turning “GPS” to “ON”. Note that in this screen you can also 

activate GPS Auto Log and Power Status Log by setting the respective fields “ON”. Interval Timer set to 30 seconds 

– can go to every 5 seconds as needed  

For GPS log conversions, RDT requires that GPS logging be activated, as above. RR Firmware 2.6G and 

beyond also has power log capability and you can activate by turning Power Status Log to “ON”. 

F7000 Series Radio (only can be used with RDT Pro) 

 

Activate Call Record 

R30 Receiver (can only be used with RDT Pro) 
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Follow Directions in Section 4 of the basic manual for that product. 

 

 

For proper viewing of .kml files, Google Earth Pro must also be installed on your computer. It is assumed 

that the user also has knowledge of how to generally operate Google Earth Pro. 

Once installed it is important that you go to “Tools->Options” in the menu and select the “General” tab.  

Make sure to highlight “Allow access to local files and personal data” as highlighted below. If you do not 

select this setting, then you will not be able to play back audio files from the Google Earth map. 

Also check Tools->Options->General ->”Show web results in external browser” for best results when 

playing back voice files from map. 

 

 

Installation 

Once the program has been purchased and downloaded following the instructions from Willow Sound 

Solution’s web site, it can then be installed. 

The program can be installed by double-clicking on the .zip file download and then double-clicking 

‘setup.exe’.  Follow the on-screen instructions after that to install. 

Registration 

Initial Registration for RDT or RDT Pro 

When you first start the program, you will get a screen that looks like this: 
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(Note, you will not get this screen if you have already licensed the product and are just upgrading.) 

If you select “Continue with Trail” you will be taken to the program and you can immediately start using. 

You will have 2 remaining days past the day you download to get the program fully licensed. When 

you’re ready to license, you can do so by selecting “Help->License Information” from the menu and 

register using the procedure described later in this section. 

If you start the program and you see the following, then your temporary license has expired. You must 

get the program’s license activated to continue to use: 

 

Registering your program is a three-step process.  
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To perform the first step, press the “(1) Copy Validating Code to Clipboard”.  

 

Once this has been done, go to the email program of your choice and paste the code that has been 

copied into your PC’s clipboard into a new email. Send the email to sales@willowsound.com. 

Shortly after you’ll receive your license activation key in a return email. Carefully select and copy that 

key into your PC’s clipboard. Then go to the screen below and select “(2) Paste from Clipboard”. 

Then, press “(3) Activate License” and you’re done. The product is now fully licensed. 

As stated earlier in this section, the program will run without activation for a total of 3 days once 

downloaded. After that, it will switch to an “unlicensed” state and most functions will not be available.  

Note that RDT is allowed to run on a total of two machines per purchased copy (one on a desktop PC 

and another on a laptop for example). No more installations will be authorized after this. If at some 

point, you wish to move your copy of RDT to a different machine, please contact 

sales@willowsound.com. 

Upgrading to RDT Pro 

If you have a licensed copy of RDT on your machine and you wish to upgrade to RDT Pro, please contact 

sales@willowsound.com. You will be issued a special coupon code where you can then go to 

www.willowsound.com and purchase RDT Pro at a discounted price. 

Once this has been done, you are now registered with Willow Sound as being eligible for RDT Pro. 

Your next step is to select “License Information from the “Help Menu”. 

You will be presented with this activation screen. 

mailto:sales@willowsound.com
mailto:sales@willowsound.com
mailto:sales@willowsound.com
http://www.willowsound.com/
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Much like initial activation press “(1) Upgrade to Pro”. This will copy the validation code into your 

clipboard. Paste this into an email and send to sales@willowsound.com. Shortly after you’ll receive your 

license activation key in a return email. Carefully select and copy that key into your PC’s clipboard. Then 

go to the screen below and select “(2) Paste from Clipboard”. 

Then, press “(3) Activate License” and you’re done. The product is now fully licensed for RDT Pro. 

Menu Functions 

File Menu 

The File menu will allow you to select settings and exit the program. 

File->Settings will give you this configuration screen: 

mailto:sales@willowsound.com
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Note 

Some of these settings may have no function depending on the model of radio you are using RDT with. 

General Settings 

Auto Detect Radio: Program will try to automatically determine if the Icom radio is connected. If so, it 

will automatically select the correct folder on the SD card for recorded audio files. You can then navigate 

to the sub-folder where you pick the file(s) you are wishing to convert. 

GPS Log Settings 

Use Radio ID in File Name: If checked, this will “pop-up” a small screen that will allow you to enter the 

unit ID of your choice. This ID would typically be the “Unit ID” of the radio if NXDN is being used, but can 

also be the radio’s ESN or any other designator you choose (up to 15 characters). The Radio ID 

programming screen will be displayed when you are converting GPS logs, right after you select the files.  

This ID will then appear prepended to the GPS log file name. It will also show up in each record inside 

the newly created .kml file. 

Not checking this will prevent the Radio ID programming field from being displayed and any .kml file 

created will have a generic name. 
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Use Local Time in Conversion: All times in the .kml file created from your GPS log will be converted to 

your local time zone (as selected on your PC). This may make file analysis easier than trying to view files 

in UTC time. 

Use Preset .kml Location for Each Conversion: This is the folder location that the .kml file created from 

your GPS log conversion will be stored. If this is unchecked, the application will prompt you to set a 

location for .kml file storage each time a GPS log conversion is run. 

.kml File Location: Enter location where you would like the .kml file created by the GPS log conversion to 

be stored. 

Voice Log Settings 

Note: local time conversion already occurs in the radio for this log so there is no option to provide UTC 

time. 

Volume Display: Voice logs will display the volume level the radio was set to when it received a call. It 

can be set to display either an absolute number from 0 to 255 or a percentage of full volume. 

Unit of Measure: Select if you wish units of measure in the converted log to be displayed in Feet/Miles 

or Meters/Kilometers 

Use Preset .kml Location for Each Conversion: This is the folder location where the .kml file created from 

your voice log conversion will be stored. If this is unchecked, the application will prompt you to set a 

location for .kml file storage each time a voice log conversion is run.  

.kml File Location: Enter location where you would like the .kml file created by the voice log conversion 

to be stored. 

Radio Port Settings 

This section is when you wish to control an Icom radio using a secondary control cable using the “USB 

Mode Select” button on the main screen. 

Baud Rate 

Select the baud rate to match your radio. Typically use the default of 4800. 

Com Port 

Select the com port you want to use to perform USB Mode Select. This is typically the cable hooked to 

the radios USB port. 

File->Exit will cause the program to terminate. 

 

USB Mode Select Settings 

Select “Mode 1” for method that allows for USB mode select state change with a single cable. Note: Only 

useful for Railroad Firmware 2.6G or later. 

Select “Mode 2” for two cable method of changing USB mode select. 
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More on this in the “USB Mode Select” section of this manual on page 22. 

Model Menu 

The model menu allows you to select the radio you wish to work with. 

For RDT, the IC-F3400/F5400 RR Series and IC-F3400/F5400 Series are available to work with. 

RDT Pro adds the IC-F7000/F7500 Series and the IC-R30. 

Keep in mind that as you select different models, any functionality restrictions will be indicated 

by the corresponding action buttons being “grayed” out. 

View Menu 

The View Menu will allow you to view already created voice logs and event logs. 

View->Voice Log 

Opens up voice log view. This table will have no entries if no conversions have been run since the 

program was started otherwise, this table will be populated with entries if a conversion has been run. 

See Voice Log Section on page 12 Voice Log Viewer 

Voice Log Viewer 

for more information. 

View->Power Log (F3400/F5400 Series Radios only with RR 2.6G or Later Firmware Installed) 

Opens up power log view. This table is derived from GPS log files will have no entries if no conversions 

have been run since the program was started otherwise, this table will be populated with entries if a 

conversion has been run. 

View-> Event Log 

Opens up event log so that you can see recent program events. 

Help Menu 

Help-> Contents F1  

Opens this help guide. 

Help-> License Information  

See “Registration” section described earlier in this manual. 

Help-> About Radio Discovery Tool 

Shows the version of the program as well as other information. 

  



11 

Action Buttons 

 

Convert Voice Logs 

Pressing the “Convert Voice Logs” button will allow you to select the voice logs of your choice for 

table/map conversion.  

Depending on settings, different things will occur when this button is activated: 

• “Auto Detect” in General Settings section 

•  
o If checked 

▪ Icom radio is connected via USB and radio is in “Card Reader Mode” 

• You will be taken to the top level directory for voice logs on the radio’s 

SD card. Pick the folder with the date you are interested in and then one 

or more voice files you wish to convert 

▪ Icom radio is not connected via USB or not in “Card Reader Mode” 

• You will get the following message 

•  
• Pressing “OK” will bring up a file selection screen to allow you to pick 

voice files from alternate locations 

o If unchecked 
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▪ Regardless whether a radio is connected or not you will get a file selection 

screen to allow you to pick voice files from alternate locations 

• “Use Preset .kml Location for each Conversion” in the Voice Log Settings section  

•  
o If checked 

▪ The voice files will be automatically copied and placed in the location as listed in 

the “.kml File Location” setting along with the newly created .kml file. 

▪ You’ll be presented with the voice log table 

o  If unchecked 

▪ You will be presented with a file selection screen so that you can determine 

what directory you want your .kml file and voice logs to be stored in 

▪ Once “OK” is pressed the voice files will be automatically copied and placed in 

the location you just chose along with the newly created .kml file. 

▪ You’ll be presented with the voice log table 

Once the file chooser is displayed, pick the file you’d like to convert. Note that more than one log file 

can be selected using standard ctrl or shift Windows conventions when picking a file. The files will all be 

combined into one .kml file. 

When the files are selected, a table is generated, and Google Earth is opened to display the information 

from the files. 

Voice Log Viewer 

When populated the voice log will contain a significant amount of metadata from the voice file – most of 

this metadata is self-explanatory. You can also open and remove additional logs if you wish. 

Open Log: Open an existing voice log table. Once pressed navigate to the voice log folder of your choice 

and open the table that ends in “_vcli.xml”. 

GeoLocate Selected Row(s): Select a row of choice by clicking anywhere in the row. Select GeoLocate to 

open this position in Google Earth. You can select multiple rows by standard ctrl or shift Windows 

conventions on desired rows. 

GeoLocate All Rows: Display Google Earth with all rows selected. 

“X” on tab: Close selected tab (note: “Current” tab cannot not be closed) 
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• Note: 

o “Click to Play” allows you to play the voice file associated with the metadata. 

o You can sort on a particular column by pressing on the column header. 

o Green rows represent RX. Red indicates TX. 

o “Date” and “Time” will always be in the time zone the radio was set to. 

o “Volume” can be displayed as an absolute number or percentage depending on how this 

is set up in the settings programming screen. 

o “Call Type”, “Call To” and “Call From” will be blank unless the transmission was NXDN 

digital. 

o “My Latitude”, “My Longitude” and “My Altitude” may be blank even if the radio has 

GPS “On”. If the GPS cannot obtain a position when the call was made or received (in-

doors, for example) it will not show a position in this table. Once GPS has locked on “My 

Altitude” may take a little bit longer to obtain a fix and so there may be a delay in the 

display of that value. 

o “RX Latitude”, “RX Longitude” and “RX Altitude” may be blank if the radio you’re 

receiving is not sending a GPS position. Keep in mind, even if the radio you’re receiving 

is set to send its GPS position, one will not be received if it does not currently have a fix. 

“RX Altitude” may take a little longer to display once a fix is achieved on the radio being 

received. 

o On the F3400/F5400 Series radio, for “RX Altitude” to display, the radio you are 

receiving must be using GGA NEMA sentence selection: 
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o   
o For RDT Pro, the F7000 series product does not record  

▪ Zone/Channel information 

▪ Volume Level 

▪ RX GPS Position from Secondary Unit 

o For RDT Pro, the R30 series product does not record 

▪ Zone/Channel or site information 

▪ Volume 

▪ TX Power (as it is an RX only unit) 

▪ Call Type 

▪ ESN Number 

Voice to .kml File 

When voice logs are first converted, Google Earth will open up and display map the information you’ve 

selected.  

It also generates a .kml file that you can work with should you close that window. To access, use your 

computer’s file system to navigate to the folder that has the target ESN value of the radio you 

converted. There you will see a .kml file with the ESN number of the converted radio which you can then 

double-click to open file in Google Earth. 

Whether you use Google Earth that was automatically opened when you converted the file, or open it 

sometime later, you will see a map that looks roughly like this: 
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Each paddle style placemark indicates the position of the radio recording the data (not the radio being 

received).  

The various placemark icons have further meaning. 

• Color indicates RSSI value. 

o Green: -100dB or better 

o Blue: -101dB to 110dB 

o Yellow: -111dB to -118dB 

o Red: less than -118dB 

o Purple: TX 

• If there is a “dot” in the paddle placemark, it means that the transmission is longer than 512ms 

(useful for potentially differentiating between a static burst and an actual transmission) 

Clicking on a placemark will show more information regarding a particular transmission or reception. 
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Example from F3400 series radio 

 

Example from F7000 Series radio (RDT Pro Only) 

 

Example from F30 Radio (RDT Pro Only) 

You can also play back the audio from a selected placemark by scrolling down on the pop-up window 

and selecting “Play Audio File” 

 

Make sure you have set Google Earth settings as recommended in the pre-requisite section for the audio 

files to play back properly. 

When using NXDN, you may be receiving radios that are sending their GPS positions (you will see “RX 

Latitude” and “RX Longitude” values in the table in this case). If so, the position of the received radio will 

be displayed using the “pushpin” icon as below. Note that the color of pushpin indicates the RSSI value 

that the recording radio received that signal at (and will have a matching paddle placemark in regards to 

time received). 
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Please note you can use the time slider tool if you’re looking for a recording during a specific period of 

time. 
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Convert GPS / Power Logs – F3400/F5400, F3400/F5400 RR Series and R30 Radios Only 

Please see the pre-requisites section for information on how to set up GPS log recording and interval. 

Pressing the “Convert GPS Logs” button (if F3400/F5400 Series or R30) or “Convert GPS / Power Logs” 

button (if F3400/F5400 RR Series) will allow you to select the GPS/Power logs of your choice for map 

conversion. In addition, it will allow you to view power related information in both a table format and on 

Google Earth. 

Depending on settings, different things will occur when this button is activated: 

• “Auto Detect” in the General Settings section 

o If checked 

▪ Icom radio is connected via USB and radio is in “Card Reader Mode” 

• You will be taken to the top level directory for GPS logs on the radio’s 

SD card. Pick the folder with the date you are interested in and then one 

or more files you wish to convert 

▪ Icom radio is not connected via USB or not in “Card Reader Mode” 

• You will get the following message 

•  
• Pressing “OK” will bring up a file selection screen to allow you to pick 

GPS logs from alternate locations 

o If unchecked 

▪ Regardless whether a radio is connected or not you will get a file selection 

screen to allow you to pick GPS logs from alternate locations 

• “Use Preset .kml Location for each Conversion” in the GPS Log Settings section 

o If checked 

▪ The GPS log will be automatically converted and placed in the location as listed 

in the “.kml File Location” setting 

▪ You’ll be returned to the main program screen 

o  If unchecked 

▪ You will be presented with a file selection screen so that you can determine 

what directory you want your .kml file to be stored in.  

▪ Once “OK” is pressed the GPS file is converted 

▪ You’ll be returned to the main program screen 

Once the file chooser is displayed, pick the file you’d like to convert. Note that more than one log file 

can be selected using standard ctrl or shift Windows conventions when picking a file. The files will all be 

combined into one .kml file. 

After the files are selected, a Google Earth will open and look something roughly like this: 
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And if Power Log information is available (if activated and using RR Firmware 2.6G or higher) then a 

table like this will display: 

 

If Google Earth has been closed and you wish to reopen the log you just converted, navigate on your 

computer’s file system to the folder you selected for the converted GPS log to be stored. Double click on 

the newly created .kml file and Google Earth will open. 

Each white circle with a black dot in the middle represents a position. The green paddle placemark 

represents the start of the track and the red paddle placemark represents the end. 

Click on any placemark to get position and speed information for that point. Also, if power information is 

available at that position, it will be displayed also. 
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Please note you can use the time slider tool if you’re looking for log information during a specific period 

of time. 
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Create Channel Announcement – F3400/F5400 and F7000/F7500 Series Radios only  

Pressing the “Create Channel Announcement” button will allow you to quickly customize channel 

announcements from recordings made from the radio itself. 

  

To use, first record the announcements that you would like into the radio itself. Make sure that the 

radio is unplugged from any USB connection and create your voice files by hitting the PTT and speaking 

your channel announcements (do this on a time when your system is little used or place a dummy load 

on the antenna as the announcements you are recording are also going out as standard transmissions). 

For best results, speak your announcements with as little pause as possible from the start of PTT and 

when you start speaking. Also, make sure you quickly release the PTT at the end of your voice 

announcements. Finally, avoid long announcements as the users may tire of listening to them after a 

period of time. 

Once you are satisfied with your announcements, connect the radio you used to record the 

announcements to the PC running RDT and place in “Card Reader” mode. 

“Browse” button: Allows you to navigate to the specific folder and file you’d like to have converted to a 

voice announcement 

“Play” button: Allows you to play back a selected file to ensure it is correct for the zone channel ID 

you’re applying 

“Zone” field: Put the zone number you’d like for the channel announcement you are creating 

“Channel” field: Put the channel number you’d like for the channel announcement you are creating 

“Create” button: Creates channel announcement in the appropriate place and format on the Icom radio 

Once you have created a channel announcement, you can proceed to the next file by going back to the 

“Browse” button. When finished, disconnect the Icom radio from the PC and power cycle the radio. The 

radio will now use the channel announcements you just created and assigned. 
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USB Mode Select - F3400/F5400 Series and F3400/F5400 RR Series Radios Only 

Some Icom F3400 series product are shipped with the SD card flap sealed shut. In addition, the USB card 

on the F5400 series is not easily user accessible. 

To access SD card data, typically, you can use the USB port on the Icom radio to connect to your 

computer and then put the radio in “Card Reader Mode”. 

There may be circumstances, however, where you do not want typical end users access to the SD Card 

through the USB port. To prevent this, you would remove the ability to activate “USB Mode Select” from 

the menu or any programmable buttons. 

If you do this, however, you now have no way to put the radio into “Card Reader” mode to move log 

data off the SD card. 

RDT’s “USB Mode Select” provides a way of switching to radio into card reader mode, even if “USB 

Mode” select has been removed from the radio’s menu or easily accessible buttons.  

There are two different methods of USB Mode Select (Mode 1 and Mode 2) which can be selected in the 

settings menu: 

 

The advantage of Mode 1 is that it is simple to put the radio into “Card Reader Mode”, but you must 

power cycle the radio to return it to “Data Transfer Mode”. This mode is particularly useful when the 

computer is local to the radio and cycling power to the radio is practical. 

The advantage of Mode 2 is that you can toggle the radio remotely between “Card Reader Mode” and 

“Data Transfer Mode” but two cables are required for it to work correctly and it is more complex to set 

up. This mode is particularly useful if not using RR Firmware 2.6G or later or you are reading a radio 

remotely and do not have a practical way to power cycle the radio. 

Mode 1 

Mode 1 is only supported by RR Firmware 2.6G or later. 
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To use Mode 1, simply connect a radio that is in “Data Transfer Mode” (default) to the computer with 

RDT using a USB cable. 

Pressing the “USB Mode Select” button will put the radio into “Card Reader Mode”. Once in that mode, 

you can proceed to convert Voice or GPS logs. 

When finished transferring logs, power cycle the radio and it will return to “Card Reader Mode”. 

  

A single USB cable between your computer and F3400 are all that’s required for Mode 1 operation 

Mode 2 

To set up “Mode 2” method of toggling USB Mode Select, certain parameters activated need to be 

activated in the radio.  Once done, you can toggle “USB Mode Select” via a second “control” cable. The 

second cable would be an Icom’s OPC-1862 cable for the F3400 series and a USB to 25 pin serial cable 

for the F5400 series. 

To have this work correctly, you first must set the following parameters on the Icom radio. 

On the “Key” menu referenced below, set  “Ext. Emer” to “USB Mode Select”. Note, you cannot actually 

use the Ext. Emer input for anything else while this setting is set. 

 

 

Next set the “Mode” field under Common->External I/O->Option->Multi-Connector/D-Sub 25pin to “PC 

CMD V2”. 
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That’s all you need to do on the radio. Note that in the portable radio, if you attempt to program 

through the Multi-Connector (not USB port) that you must press “P1” first to bypass temporarily the PC 

CMD V2 setting. 

Make sure that your com port is properly set in the settings menu. You will now be able to toggle modes 

as needed with the USB Mode Select button. 

There is no way at this time to determine the state of this button other than looking at the radio as you 

press the USB Mode Select button. But if it is in card reader mode and an SD card exists in the Icom 

radio, the SD card should mount on your desktop. 

Pressing the button again should cause the SD card to disappear from Window’s file explorer. This 

should be another indication to you that the card is back in “Data Transfer” mode. Please make sure you 

set the radio to “Data Transfer Mode” if you wish to program the radio via the USB port. 

*Please note that it is very important that you leave the radio in “Data Transfer” mode while 

recording audio files. If you leave it in “Card Reader” mode AND have a USB cable connect to a 

computer, the radio will not be able to store log files. 
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Using an OPC-1862 as a “control cable” to toggle USB Mode Select for F3400 series 

 

Using an USB to DB25 adapter as a “control cable” to toggle USB Mode Select for F5400 series. Note: the 

USB to DB25 connection will typically consist of a USB to 9 pin converter and then a 9 pin to 25 pin 

adapter. Willow Sound Solutions has successfully used a US Converters Model XS880 converter and a 

generic null-modem 9 to 25 pin adapter cable. 

Remote Access using USB Mode Select 

To remotely access an Icom radio for the purposes converting voice and GPS logs, the following method 

has been shown to work in limited tested. Be aware that Willow Sound Solutions does not offer support 

for this technique and that this setup is being provided for informational purposes only. 

For this method to work, you will need to obtain a Silex DS-510 USB device server. Follow the direction 

that comes with the device to configure it to work on your network and install the SX Virtual Link 

software on the same computer that is running RDT. 

You will also need to configure your radios as described in the first part of this section. 

You will connect your Icom radio to the Silex USB Device server as in the graphics below. 
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Connecting a Silex USB Device Server to a F5400D 

 

 

Connecting a Silex USB device server to a F3400 

 

Here is an example of what the SX Virtual Link software will look like when the Silex USB device server is 

successfully hooked to a powered-on F3400 using one USB and one OPC-1862 cable 
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SX Virtual Link Software with Icom radio connected. Note that the “Icom Inc. Icom Radio” port is 

currently connected as a “hard drive” (hence the icon) using the USB cable. The “Prolific Technology” port 

is the OPC-1862 control cable (note the icon associated with it).  

Note, for speedy reconnection, on each port, right click and select “Automatically connect the device 

when it is available” as shown below. 
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Once successfully connected, you can use the “USB Mode Select” button just as if the radio is local. 

Note:  

This application is for reading the files on the SD Card. Using this method to try and read the radios using 

the cloning software has not been successful. 

If you wish to update a remote radio, the recommended way is to transfer the .icf file or firmware to the 

SD card. Then locally update the radio using the menu commands built into the radio. 


